re = /<.*> */
str = '<!--/* Font Definitions */@font-face{font-family:Wingdings;panose-1:5 0 0 0 0 0 0 0 0 0;}@font-
face...bottom:0in;}--> pop goes the peanut.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result