using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s]+)\s*:\s*(.*?)\s*(?=[^\s]+:|$)";
string input = @"address: C/O John Smith @ Building X, S/W city: new york state: new york population: 500000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}