re = /([^\s]+)\s*:\s*(.*?)\s*(?=[^\s]+:|$)/m
str = 'address: C/O John Smith @ Building X, S/W city: new york state: new york population: 500000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end