$re = '/([^\s]+)\s*:\s*(.*?)\s*(?=[^\s]+:|$)/m';
$str = 'address: C/O John Smith @ Building X, S/W city: new york state: new york population: 500000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);