package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<searched_type>(index|source|sourcetype))(?:\W+)(?<searched_value>\S[^\s|\||\"]+)`)
var str = `search index="application_sec_pr_secure"|delete
search index = application_sec_pr secure sourcetype=aaa | delete
search index=infra_aaa_summary* sourcetype=aaa | delete
search * sourcetype=aaa | delete`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}