// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?<searched_type>(index|source|sourcetype))(?:\W+)(?<searched_value>\S[^\s|\||\"]+)"#).unwrap();
let string = "search index=\"application_sec_pr_secure\"|delete
search index = application_sec_pr secure sourcetype=aaa | delete
search index=infra_aaa_summary* sourcetype=aaa | delete
search * sourcetype=aaa | delete";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}