re = /(?<searched_type>(index|source|sourcetype))(?:\W+)(?<searched_value>\S[^\s|\||\"]+)/m
str = 'search index="application_sec_pr_secure"|delete
search index = application_sec_pr secure sourcetype=aaa | delete
search index=infra_aaa_summary* sourcetype=aaa | delete
search * sourcetype=aaa | delete'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end