#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\A(\d+)X.*\Z"
Local $sString = "455XYZ455"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)