using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A(\d+)X.*\Z";
string substitution = @"\1";
string input = @"455XYZ455";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}