using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/example\.com(?=\s|$)";
string input = @"our website https://example.com lorem ipsum, dolor sit amet https://example.com/pizza, here is cheese
https://example.com/cheese, dont forget to click https://example.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}