$re = '/https:\/\/example\.com(?=\s|$)/m';
$str = 'our website https://example.com lorem ipsum, dolor sit amet https://example.com/pizza, here is cheese
https://example.com/cheese, dont forget to click https://example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);