re = /https:\/\/example\.com(?=\s|$)/m
str = 'our website https://example.com lorem ipsum, dolor sit amet https://example.com/pizza, here is cheese
https://example.com/cheese, dont forget to click https://example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end