package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/+([\w\/]+?)\/+$`)
var str = `/some/url/here/
//some/other/url/here///
//some comment in some text///
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}