re = /^\/+([\w\/]+?)\/+$/m
str = '/some/url/here/
//some/other/url/here///
//some comment in some text///
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end