$re = '/^\/+([\w\/]+?)\/+$/m';
$str = '/some/url/here/
//some/other/url/here///
//some comment in some text///
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);