package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)get\(.*,\s*'(.+)',\s*(.+)\)`)
var str = `get(store, 'data.field1.field2', defaultVal)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}