re = /get\(.*,\s*'(.+)',\s*(.+)\)/m
str = 'get(store, \'data.field1.field2\', defaultVal)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end