$re = '/get\(.*,\s*\'(.+)\',\s*(.+)\)/m';
$str = 'get(store, \'data.field1.field2\', defaultVal)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);