#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!cpc)((lifull-connect|facebook|mitula).*(referrer|referral))|bpihousingloans|rumah\.mitula|dotproperty\/blog-property-boost"
Local $sString = "lm.facebook.com" & @CRLF & _
"facebook/social/listing" & @CRLF & _
"en-gb.facebook.com" & @CRLF & _
"lifull-connect/cpc/premium" & @CRLF & _
"mitula/cpc/feed-client" & @CRLF & _
"mitula/cpc/feed-default" & @CRLF & _
"baan.mitula.in.th" & @CRLF & _
"mitula/feed-client" & @CRLF & _
"dotproperty/email/send-alert" & @CRLF & _
"dotproperty/email/send-alert-interest" & @CRLF & _
"dotproperty/email/enquiry" & @CRLF & _
"dotproperty/email/click-to-call-property" & @CRLF & _
"dotproperty/webpush/alert" & @CRLF & _
"dotproperty/webpush/new-home" & @CRLF & _
"dotproperty/android_app" & @CRLF & _
"dotproperty.co.th" & @CRLF & _
"dotpropertygroup.com" & @CRLF & _
"facebook/cpc/[facebook][cpc][house][sale]" & @CRLF & _
"lifull-connect/referrer/feed-client" & @CRLF & _
"lifull-connect/referrer/feed-default" & @CRLF & _
"directory.bpihousingloans.com" & @CRLF & _
"lifull-connect/referrer/feed-featured" & @CRLF & _
"rumah.mitula.co.id" & @CRLF & _
"lifull-connect/referrer/feed-boost" & @CRLF & _
"facebook/referral/[facebook][marketplace][condo][rent]" & @CRLF & _
"dotproperty/blog-property-boost" & @CRLF & _
"facebook/referral/[facebook][marketplace][house][rent]" & @CRLF & _
"facebook/referral/[facebook][marketplace][townhouse][rent]" & @CRLF & _
"mitula/referrer/feed-client" & @CRLF & _
"facebook/referral/[facebook][marketplace][condo][sale]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")