using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!cpc)((lifull-connect|facebook|mitula).*(referrer|referral))|bpihousingloans|rumah\.mitula|dotproperty\/blog-property-boost";
string input = @"lm.facebook.com
facebook/social/listing
en-gb.facebook.com
lifull-connect/cpc/premium
mitula/cpc/feed-client
mitula/cpc/feed-default
baan.mitula.in.th
mitula/feed-client
dotproperty/email/send-alert
dotproperty/email/send-alert-interest
dotproperty/email/enquiry
dotproperty/email/click-to-call-property
dotproperty/webpush/alert
dotproperty/webpush/new-home
dotproperty/android_app
dotproperty.co.th
dotpropertygroup.com
facebook/cpc/[facebook][cpc][house][sale]
lifull-connect/referrer/feed-client
lifull-connect/referrer/feed-default
directory.bpihousingloans.com
lifull-connect/referrer/feed-featured
rumah.mitula.co.id
lifull-connect/referrer/feed-boost
facebook/referral/[facebook][marketplace][condo][rent]
dotproperty/blog-property-boost
facebook/referral/[facebook][marketplace][house][rent]
facebook/referral/[facebook][marketplace][townhouse][rent]
mitula/referrer/feed-client
facebook/referral/[facebook][marketplace][condo][sale]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}