import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!cpc)((lifull-connect|facebook|mitula).*(referrer|referral))|bpihousingloans|rumah\\.mitula|dotproperty\\/blog-property-boost";
final String string = "lm.facebook.com\n"
+ "facebook/social/listing\n"
+ "en-gb.facebook.com\n"
+ "lifull-connect/cpc/premium\n"
+ "mitula/cpc/feed-client\n"
+ "mitula/cpc/feed-default\n"
+ "baan.mitula.in.th\n"
+ "mitula/feed-client\n"
+ "dotproperty/email/send-alert\n"
+ "dotproperty/email/send-alert-interest\n"
+ "dotproperty/email/enquiry\n"
+ "dotproperty/email/click-to-call-property\n"
+ "dotproperty/webpush/alert\n"
+ "dotproperty/webpush/new-home\n"
+ "dotproperty/android_app\n"
+ "dotproperty.co.th\n"
+ "dotpropertygroup.com\n"
+ "facebook/cpc/[facebook][cpc][house][sale]\n"
+ "lifull-connect/referrer/feed-client\n"
+ "lifull-connect/referrer/feed-default\n"
+ "directory.bpihousingloans.com\n"
+ "lifull-connect/referrer/feed-featured\n"
+ "rumah.mitula.co.id\n"
+ "lifull-connect/referrer/feed-boost\n"
+ "facebook/referral/[facebook][marketplace][condo][rent]\n"
+ "dotproperty/blog-property-boost\n"
+ "facebook/referral/[facebook][marketplace][house][rent]\n"
+ "facebook/referral/[facebook][marketplace][townhouse][rent]\n"
+ "mitula/referrer/feed-client\n"
+ "facebook/referral/[facebook][marketplace][condo][sale]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}