using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S\s@\s+\K\d+(?:\.\d+)?";
string input = @"Strip @ 489.000
Strip 1 @ 489.000
Strip 2 @ 589.000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}