re = /\S\s@\s+\K\d+(?:\.\d+)?/m
str = 'Strip @ 489.000
Strip 1 @ 489.000
Strip 2 @ 589.000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end