$re = '/(\S+)\s\1/';
$str = 'Deep episodes of Deep Space Nine came on the television only after the news.
Digital alarm clocks scare area children ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);