import re
regex = re.compile(r"(\S+)\s\1")
test_str = ("Deep episodes of Deep Space Nine came on the television only after the news.\n"
"Digital alarm clocks scare area children ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")