#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Z0-9._%-]+@[A-Z0-9.-]+\.[A-Z]{2,4}\.[A-Z]{2,4}"
Local $sString = "Email: regex_cpp@net.br Valid" & @CRLF & _
"Email: regex_cpp@terra.com.br Valid" & @CRLF & _
"Email: regex_cpp@hotmail.com.br.net Valid (não pode validar)" & @CRLF & _
"Email: regex_cpp@hotmail.com Valid" & @CRLF & _
"Email: regex_cpp@yahoo.com.br Valid" & @CRLF & _
"Email: regex_cpp@gmail.com Valid" & @CRLF & _
"Email: regex_cpp@bol.com.br Valid" & @CRLF & _
"Email: regex.cpp@bol.com Valid" & @CRLF & _
"Email: reg_ex.cpp@bol.com Valid" & @CRLF & _
"Email: reg_ex.cpp@org.br Valid" & @CRLF & _
"Email: reg_ex.cpp@net.org.br Valid"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")