import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z0-9._%-]+@[A-Z0-9.-]+\\.[A-Z]{2,4}\\.[A-Z]{2,4}";
final String string = "Email: regex_cpp@net.br Valid\n"
+ "Email: regex_cpp@terra.com.br Valid\n"
+ "Email: regex_cpp@hotmail.com.br.net Valid (não pode validar)\n"
+ "Email: regex_cpp@hotmail.com Valid\n"
+ "Email: regex_cpp@yahoo.com.br Valid\n"
+ "Email: regex_cpp@gmail.com Valid\n"
+ "Email: regex_cpp@bol.com.br Valid\n"
+ "Email: regex.cpp@bol.com Valid\n"
+ "Email: reg_ex.cpp@bol.com Valid\n"
+ "Email: reg_ex.cpp@org.br Valid\n"
+ "Email: reg_ex.cpp@net.org.br Valid";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}