use strict;
my $str = 'Email: regex_cpp@net.br Valid
Email: regex_cpp@terra.com.br Valid
Email: regex_cpp@hotmail.com.br.net Valid (não pode validar)
Email: regex_cpp@hotmail.com Valid
Email: regex_cpp@yahoo.com.br Valid
Email: regex_cpp@gmail.com Valid
Email: regex_cpp@bol.com.br Valid
Email: regex.cpp@bol.com Valid
Email: reg_ex.cpp@bol.com Valid
Email: reg_ex.cpp@org.br Valid
Email: reg_ex.cpp@net.org.br Valid';
my $regex = qr/[A-Z0-9._%-]+@[A-Z0-9.-]+\.[A-Z]{2,4}\.[A-Z]{2,4}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}