package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<host>\d+(?:\.\d+){3})
\s+\S+\s+
(?P<user_name>\S+)\s+\[
(?P<time>[^\]\[]*)\]\s+
"(?P<request>[^"]*)"`)
var str = `159.253.153.40 - - [21/Jun/2019:15:46:10 -0700] "POST /e-business HTTP/1.0" 504 19845
136.195.158.6 - feeney9464 [21/Jun/2019:15:46:11 -0700] "HEAD /open-source/markets HTTP/2.0" 204 21149
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}