// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mx)(?P<host>\d+(?:\.\d+){3})
\s+\S+\s+
(?P<user_name>\S+)\s+\[
(?P<time>[^\]\[]*)\]\s+
"(?P<request>[^"]*)""#).unwrap();
let string = "159.253.153.40 - - [21/Jun/2019:15:46:10 -0700] \"POST /e-business HTTP/1.0\" 504 19845
136.195.158.6 - feeney9464 [21/Jun/2019:15:46:11 -0700] \"HEAD /open-source/markets HTTP/2.0\" 204 21149
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}