# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r'''
(?P<host>\d+(?:\.\d+){3})
\s+\S+\s+
(?P<user_name>\S+)\s+\[
(?P<time>[^\]\[]*)\]\s+
"(?P<request>[^"]*)"
'''
test_str = ("159.253.153.40 - - [21/Jun/2019:15:46:10 -0700] \"POST /e-business HTTP/1.0\" 504 19845\n\n"
"136.195.158.6 - feeney9464 [21/Jun/2019:15:46:11 -0700] \"HEAD /open-source/markets HTTP/2.0\" 204 21149\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur'' to prefix the regex and u"" to prefix the test string and substitution.