package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)dev`)
var str = `thatdevmachine.something.com
thisDEVmachine.something.com
otherDeVmachine.comsthing.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}