re = /(?i)dev/m
str = 'thatdevmachine.something.com
thisDEVmachine.something.com
otherDeVmachine.comsthing.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end