$re = '/(?i)dev/m';
$str = 'thatdevmachine.something.com
thisDEVmachine.something.com
otherDeVmachine.comsthing.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);