import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{3,50}$)[^\\s\\d]*(\\s[^\\s\\d]*)?$";
final String string = "I need a RegEx to match the following condition:\n\n"
+ "1 or 2 words\n"
+ "Total minimum length is 3\n"
+ "Total maximum length is 50\n"
+ "Accept accented characters\n"
+ "No numbers is a plus\n"
+ "Examples of accepted strings: dfg dfg dfg sdfg dasfg \n\n"
+ "Karmen Garcia\n"
+ "João Pedro\n"
+ "Vitor\n"
+ "maxiliamum Lófffffffffffffffffffffffffffffffffffff\n"
+ "Nadál\n"
+ "loriPsium PsisVõèrbizbbbbbbbbbb\n"
+ "Examples of non accepted string:\n\n"
+ "Jony Cam Vanis\n"
+ "kljsdfklsdfkljsfkldsfkljs dsfkljsdlfldjsfkldjsfljsdlkfjls\n"
+ "sdlfkjsdklfjklsdfjkljsfjsdfljsdlfjsdfkljsdfkljsdlfkjlksf\n"
+ "9lucas P.us-kas1 Li1\n"
+ "What I tried:\n\n"
+ "^(?!.*?\\s{2})[A-Za-z ]{3,50}$\n"
+ "^([a-zA-Z][a-zA-Z]){3,50}$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}