import re
regex = re.compile(r"^(?=.{3,50}$)[^\s\d]*(\s[^\s\d]*)?$", flags=re.MULTILINE)
test_str = ("I need a RegEx to match the following condition:\n\n"
"1 or 2 words\n"
"Total minimum length is 3\n"
"Total maximum length is 50\n"
"Accept accented characters\n"
"No numbers is a plus\n"
"Examples of accepted strings: dfg dfg dfg sdfg dasfg \n\n"
"Karmen Garcia\n"
"João Pedro\n"
"Vitor\n"
"maxiliamum Lófffffffffffffffffffffffffffffffffffff\n"
"Nadál\n"
"loriPsium PsisVõèrbizbbbbbbbbbb\n"
"Examples of non accepted string:\n\n"
"Jony Cam Vanis\n"
"kljsdfklsdfkljsfkldsfkljs dsfkljsdlfldjsfkldjsfljsdlkfjls\n"
"sdlfkjsdklfjklsdfjkljsfjsdfljsdlfjsdfkljsdfkljsdlfkjlksf\n"
"9lucas P.us-kas1 Li1\n"
"What I tried:\n\n"
"^(?!.*?\\s{2})[A-Za-z ]{3,50}$\n"
"^([a-zA-Z][a-zA-Z]){3,50}$")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")