#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(Charlie)(?=\W+(?:\w+\W+){1,10}?plot)|((?<=plot)\W+(?:\w+\W+){1,10}?)(Charlie)|(Charlie)(?=\W+(?:\w+\W+){1,10}?over)|((?<=plot)\W+(?:\w+\W+){1,10}?)(Charlie)"
Local $sString = "Charlie was over the moon" & @CRLF & _
"Mr Muir was bowled over" & @CRLF & _
"over was the the moon Charlie" & @CRLF & _
"Charlie was near the plot" & @CRLF & _
"" & @CRLF & _
"Charlie was far away from the plot was far away from the" & @CRLF & _
"" & @CRLF & _
"the plot was far away from Charlie"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")