$re = '/(Charlie)(?=\W+(?:\w+\W+){1,10}?plot)|((?<=plot)\W+(?:\w+\W+){1,10}?)(Charlie)|(Charlie)(?=\W+(?:\w+\W+){1,10}?over)|((?<=plot)\W+(?:\w+\W+){1,10}?)(Charlie)/m';
$str = 'Charlie was over the moon
Mr Muir was bowled over
over was the the moon Charlie
Charlie was near the plot
Charlie was far away from the plot was far away from the
the plot was far away from Charlie';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);