use strict;
my $str = 'Charlie was over the moon
Mr Muir was bowled over
over was the the moon Charlie
Charlie was near the plot
Charlie was far away from the plot was far away from the
the plot was far away from Charlie';
my $regex = qr/(Charlie)(?=\W+(?:\w+\W+){1,10}?plot)|((?<=plot)\W+(?:\w+\W+){1,10}?)(Charlie)|(Charlie)(?=\W+(?:\w+\W+){1,10}?over)|((?<=plot)\W+(?:\w+\W+){1,10}?)(Charlie)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}