package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s-\s|[(),\s]`)
var str = `T1 - X1(1), 7
T2 - C2(-9), -15
T3 - Y2(1), 3
T5 - C2(-1), 100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}