import re
regex = re.compile(r"\s-\s|[(),\s]", flags=re.MULTILINE)
test_str = ("T1 - X1(1), 7\n"
"T2 - C2(-9), -15\n"
"T3 - Y2(1), 3\n"
"T5 - C2(-1), 100")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")