# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^a-zA-Z ]+\S*/ /gm;t' <<< "Brown 1fox jum'ps'test over 9 8test8$ninetest8.. the_t la8zy dog."