use strict;
my $str = 'Brown 1fox jum\'ps\'test over 9 8test8$ninetest8.. the_t la8zy dog.';
my $regex = qr/[^a-zA-Z ]+\S*/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";