$re = '/[^a-zA-Z ]+\S*/m';
$str = 'Brown 1fox jum\'ps\'test over 9 8test8$ninetest8.. the_t la8zy dog.';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;