package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[ \[SmokeDetector\]\(\/\/git\.io\/vyDZv\)(?: \| \[MS\]\([\w.\/]*+\))? \] (?:\w*+ )*+\(\**+\d++\**+\): \[.*\]\(\/\/[\w.\/]*\/(\d++)\) by \[.*\]\(\/\/[\w.\/]*+\) on `([\w.]*+)`$`)
var str = `[ [SmokeDetector](//git.io/vyDZv) ] Potentially bad keyword in answer (1): [Opioids are addictive or cause dependency issues only? ✏️](//medicalsciences.stackexchange.com/a/24672) by [Chukwuyem Obiazi](//medicalsciences.stackexchange.com/users/20377) on \`medicalsciences.SE\``
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}