$re = '/^\[ \[SmokeDetector\]\(\/\/git\.io\/vyDZv\)(?: \| \[MS\]\([\w.\/]*+\))? \] (?:\w*+ )*+\(\**+\d++\**+\): \[.*\]\(\/\/[\w.\/]*\/(\d++)\) by \[.*\]\(\/\/[\w.\/]*+\) on `([\w.]*+)`$/m';
$str = '[ [SmokeDetector](//git.io/vyDZv) ] Potentially bad keyword in answer (1): [Opioids are addictive or cause dependency issues only? ✏️](//medicalsciences.stackexchange.com/a/24672) by [Chukwuyem Obiazi](//medicalsciences.stackexchange.com/users/20377) on `medicalsciences.SE`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);