import Foundation
let pattern = #"^\[ \[SmokeDetector\]\(\/\/git\.io\/vyDZv\)(?: \| \[MS\]\([\w.\/]*+\))? \] (?:\w*+ )*+\(\**+\d++\**+\): \[.*\]\(\/\/[\w.\/]*\/(\d++)\) by \[.*\]\(\/\/[\w.\/]*+\) on `([\w.]*+)`$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[ [SmokeDetector](//git.io/vyDZv) ] Potentially bad keyword in answer (1): [Opioids are addictive or cause dependency issues only? ✏️](//medicalsciences.stackexchange.com/a/24672) by [Chukwuyem Obiazi](//medicalsciences.stackexchange.com/users/20377) on `medicalsciences.SE`"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)