package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:Mr|U\.S|U\.K)\.(*SKIP)(*F)|\.\s+`)
var str = `My name is Mr. Aishwarya. I live in the U.K. and want to go to U.S. Us will go to Australi. Who else wants to go to U.S.A. ? My wife's name is Ruchika Bhatt. `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}