const regex = /\b(?:Mr|U\.S|U\.K)\.(*SKIP)(*F)|\.\s+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:Mr|U\\.S|U\\.K)\\.(*SKIP)(*F)|\\.\\s+', 'gm')
const str = `My name is Mr. Aishwarya. I live in the U.K. and want to go to U.S. Us will go to Australi. Who else wants to go to U.S.A. ? My wife's name is Ruchika Bhatt. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}