$re = '/\b(?:Mr|U\.S|U\.K)\.(*SKIP)(*F)|\.\s+/m';
$str = 'My name is Mr. Aishwarya. I live in the U.K. and want to go to U.S. Us will go to Australi. Who else wants to go to U.S.A. ? My wife\'s name is Ruchika Bhatt. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);